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CHAPTER

ONE

BENCHTOP SYSTEM OVERVIEW

Resonon’s benchtop hyperspectral imaging system is comprised of a Pika hyperspectral imaging camera, linear trans-
lation stage, mounting tower, lighting assembly, and software control system. The positions of the imager and lighting
assembly are adjustable along the length of the tower. See Figure 1 below.

Resonon’s hyperspectral imagers are line-scan imagers (also referred to as push-broom imagers). Two-dimensional
images are constructed by translating the sample relative to the camera. This is typically accomplished by placing the
sample on a linear translation stage.

Fig. 1: Figure 1. Benchtop hyperspectral imaging system

Resonon’s Pika imaging spectrometers are compact, high fidelity, digital instruments for industrial and scientific ap-
plications. Spectronon is a powerful hyperspectral data visualization and analysis software package we provide as a
free download. Spectronon is easy to learn, offers efficient workflow, and is highly extensible by the user for custom
applications. Additionally, a number of datacubes can be downloaded from the Resonon website (www.resonon.com)
so you can begin exploring hyperspectral data within a few minutes.
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SpectrononPro has all the features of Spectronon, but also includes data collection tools that are highly integrated with
our Pika imaging spectrometers to streamline the collection of spectral images.

2 Chapter 1. Benchtop System Overview



CHAPTER

TWO

BASIC DATA ACQUISITION

2.1 Data Modes and Sources

It is important to consider the data mode of the various hyperspectral imaging systems that produce hyperspectral
datacubes. Hyperspectral data from Resonon imaging systems can be utilized in three forms, as summarized below.
Which modes are used is application dependent, and affects subsequent datacube analyses.

2.1.1 Raw Data

These data are spectrally calibrated but are not corrected for the instrument-sensor-response or illumination functions,
so the result cannot be directly interpreted as, for example, reflectivity. The units are digital number (DN) from the
imager camera’s sensor array. If a dark frame has been recorded, these data may have the camera’s average dark current
subtracted, but no other correction are applied. This is the least useful data form, as the spectral curves do not have
physical units. SpectrononPro can collect datacubes in this mode with either a Benchtop System or Outdoor Field
System.

2.1.2 Radiance

Raw data can be post-processed to give radiance data, where the DN unit is converted to physical units of microflicks
(1 microflick = 1 microwatt per steradian per square centimeter of surface per micrometer of span in wavelength). This
mode removes the imager’s instrument-sensor-response function from the data. This function is corrected for by using
the Imager Calibration Pack (ICP file) with the Radiance Conversion plugin. See the Spectronon user manual section
“Advanced Data Analysis 1”. The resulting data are the product of illumination and sample-reflectivity functions. In
addition to the standard spectral calibration, radiance measurements require Resonon to perform a radiometric calibra-
tion (rad cal) on the imager with the desired objective-lens aperture. Radiance conversions are typically performed with
Spectronon[Pro] on datacubes collected under stable, uniform lighting conditions, such as with Resonon’s Outdoor
Field System or Airborne Remote Sensing System.

2.1.3 Reflectivity/Reflectance

In reflectance mode, both the instrument-sensor-response and illumination functions are removed. This leaves the data
in absolute reflectance. Resonon’s Benchtop System commonly performs reflectance measurements on a sample by
applying a response correction that employs a separate scan of a reflectance standard that corrects for the instrument-
sensor-response and illumination functions. The reflectance standard, or calibration tile (cal tile), fills the entire field
of view (FOV) of the imager. Spectralon® and Fluorilon® are the highest quality reflection standards, but Teflon is
acceptable for many applications. (Teflon needs to be sanded with 100 grit sandpaper on an orbital sander to eliminate
any specular properties).

3
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In other system setups, such as with Resonon’s Outdoor Field System or Airborne Remote Sensing System, data can
be converted to reflectance in one of four ways described below.

1. White reference: Data can be processed to reflectance with a calibration measurement against a re-
flectance standard, such as used with the Benchtop System. This calibration is done with the Record
Correction Cube feature, as described in the Spectronon user manual under “Imager Calibration”. It is
important to note that reflectance values are only accurate if the solar illumination (cloud, sun angle, etc.)
does not change between the collection of the response-correction datacube and the sample datacube.
Data can also be converted to reflectance using Spectronon’s Reflectance Conversion from Spectrally
Flat Reference Cube plugin. See the Spectronon user manual section “Advanced Data Analysis 1”.

2. Known spectral reference in scene: After the data have been converted to radiance, the known spec-
trum of a reference object in the scene can be used to correct the rest of the cube to reflectance. The
reference spectrum must be known and in a tab- or space-delimited file. Use the Convert Radiance Cube
to Reflectivity from Spectrally Flat Reference Spectrum plugin. See the Spectronon user manual sec-
tion “Advanced Data Analysis 1”.

3. Downwelling irradiance sensor: An alternative method for converting data to reflectance is to use a
downwelling irradiance sensor. This sensor records the solar spectrum during data acquisition. This data
is used, along with the Imager Calibration Pack (ICP) file(s) supplied by Resonon for both the spectral
imager and the downwelling sensor. This method uses the Reflectivity Conversion from Downwelling
Irradiance Data plugin. See the Spectronon user manual section “Advanced Data Analysis 1”.

4. Atmospheric Correction: Data can be converted to reflectance with the use of atmospheric correction
algorithms such as FLAASH (Fast Line of Sight Atmospheric Analysis of Spectral Hypercubes). Please
contact Resonon for more information.

2.2 Start The System

If you have an illumination system, turn it on and let it warm up sufficiently. Some lights may require 15 to 20 minutes
to fully stabilize.

With the imager and (optional) stage connected to your computer, launch Spectronon[Pro] by double-clicking on
the Spectronon[Pro] icon or starting Spectronon[Pro] from your Start menu. The SpectrononPro icon and user
interface are shown below with the various windows labeled.

4 Chapter 2. Basic Data Acquisition
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Once the software has started, make sure that the imager and stage controls (if used) are enabled, which indicates that
they are properly connected. The imager and stage tools will be greyed out if not enabled, as shown below.

You can get the latest version of Spectronon[Pro] by clicking on Help → Check For Updates. This won’t download
the latest version, but will give an alert if there is a newer version, as well as a hyperlink to it.

2.2. Start The System 5
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2.3 Verifying Imager Calibration

From the Main menu, select File → Preferences. . . .

This will reveal the Preferences window. This window has several tabbed panes that provide detailed information
about the connected Imager and Stage, as well as settings for the Scanner, managing and analyzing datacubes on the
Workbench, and visualizing data with Plotters.

6 Chapter 2. Basic Data Acquisition
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In the Preferences window, select the Imager tab to reveal detailed information about your connected hyperspectral
imager. Your imager was calibrated at the factory. The spectral calibration numbers are provided on a sheet that comes
with your imager and should be verified prior to use. Check the A, B, and C values from the sheet provided against the
Spectral Calibration values appearing in SpectrononPro. If you cannot locate your calibration sheet or these numbers
differ from those reported in the software, then please contact Resonon at: ProductSupport@resonon.com.

2.4 Imager Controls

Camera Settings for the imager can be controlled by clicking on the Imager tab in the Tools panel in the Main window.

Fig. 1: Imager Camera Settings with Auto Framerate Mode off.

Framerate is equal to the number of datacube lines acquired each second, or frames per second (fps). The Framerate
limits the maximum Integration Time, where typically Integration Time ≤ 1 / Framerate.

Integration Time is the duration of data acquisition for each individual line (also known as exposure time), displayed
in milliseconds (ms). Larger integration times require smaller frame rates, and smaller integration times allow faster
frame rates. Integration times that are too short have poor signal-to-noise ratio. Integration times that are too long
saturate pixels in the detector.

Gain is a factor that increases the signal, but at the expense of signal-to-noise ratio. Keep the gain as low as possible,
preferably zero. A gain of 6 dB roughly doubles the signal. (The IR imagers do not have this setting.)

Some of Resonon’s imagers support Auto Framerate Mode. When enabled, the Framerate cannot be set directly.
(However, the frame rate can still be viewed.) The user need only select an appropriate Integration Time (and Gain,
possibly) based on the illumination and sample brightness, and SpectrononPro automatically chooses the fastest
Framerate for that Integration Time. This helps produce the fastest possible scans for a given setup.

2.4. Imager Controls 7

mailto:ProductSupport@resonon.com


Benchtop Quick Start for Spectronon Version 3.4.11

Fig. 2: Imager Camera Settings with Auto Framerate Mode on.

Additional Imager settings are available in Preferences–>Imager, described in Section {number}: {name}.

2.5 Stage Controls

The stage is configured at the factory for either the Benchtop System (cm units) or the Outdoor Field System (deg units).
You can move the stage manually by clicking on the Jog Stage buttons, located on the toolbar. The buttons move the
stage incrementally in either direction. Use the buttons to center the stage underneath the Pika imaging spectrometer.

The stage can be further controlled by clicking on the Stage tab in the Tools panel. The default stage setting in
SpectrononPro is Auto Speed Mode. This means that the Framerate of the imager’s camera is used to automati-
cally calculate the stage’s Scanning Speed. Because the imager is a line-scan imager, the stage must traverse at a speed
proportional to the camera’s framerate in order to capture the scene with a unit aspect ratio. If the stage is too slow
with respect to the Framerate, then the image is elongated in the direction of stage travel. If the stage is too fast with
respect to the Framerate, then the image is shortened.

8 Chapter 2. Basic Data Acquisition
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For the Benchtop System, the Swath value is key to achieving unit aspect ratio scans when using Auto Speed Mode.
The swath is the width of the stage that is viewed by the imager, and is affected by the choice of objective lens and
the working distance from the (in-focus) object on the stage to the imager. A procedure for determining a value for
Swath is provided later in Section {number}: {name}. In the Outdoor Field System, this Swath is replaced by the
angular FOV (field of view), which is typically the far-field value specified for the given objective lens.

With Auto Speed Mode selected, several controls are disabled and serve only as value indicators. The Scanning Speed
indicates the continuous scanning speed, and is set automatically. If the stage cannot move sufficiently slowly in a
continuous manner, then Stepping Mode will be enabled. In Stepping mode the datacube is acquired line-by-line
with the stage coming to a stop for each line, i.e., stepping. (Stepping occurs for a sufficiently long Integration Time
corresponding to a sufficiently low Framerate.) The Step Size parameter indicates how much each line in the scan
covers (continuous or stepping).

If Go Home After Scan is selected, then the stage will return to its starting position after each scan. The speed at
which the stage returns to its original position is the Homing Speed. (The Homing Speed setting is also used to set
the between-steps Scanning Speed when the stage is automatically put into Stepping Mode.) Jogging Speed is used for
the Jog Stage buttons, described above. Reverse Direction reverses the scan direction of the stage, including the jog
directions.

Additional Stage settings are available in Preferences–>Stage, described in Section {number}: {name}.

2.5. Stage Controls 9
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2.6 Focusing Objective Lens

You are now ready to focus the objective lens of your Pika imaging spectrometer. At first, this process can be somewhat

challenging, but with a little practice it becomes straightforward. Begin by clicking on the Focus button located
on the SpectrononPro tool bar. This will reveal a live image of individual frames from the imager’s camera. (Wave
your hand in the field of view (FOV) of the imager to confirm that the image is a live view.) One axis of this image
represents the spatial (position) axis of your object, and the other is the spectral (wavelength) axis. (To understand this
view better, move colored objects within the FOV of your imager after you have focused the objective lens.)

Place an object with multiple light and dark regions within your Pika imaging spectrometer’s FOV. For the Benchtop
System, make sure that the illumination is adequate and sufficiently uniform, and place a sheet of paper with dark lines
on the stage, as provided in Focusing & Calibration Sheets. For the Outdoor Field System, if you are in the field and
are observing objects at a distance, then direct the imager towards an object with multiple features, such as a tree with
many branches. Unless your lens is already focused, you will see a series of blurry or barely discernible lines in the
live-view image in the center panel of SpectrononPro.

To adjust the focus, first unlock the focus adjustment. With Schneider lenses, this is done by loosening the locking
metal collar on your objective lens using an Allen wrench, size 5/64 inch.

10 Chapter 2. Basic Data Acquisition
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Then rotate the objective lens until you see dark lines from your object come into focus, as shown. Maximize the
sharpness of the lines.

Hint: Clicking the Inspector Tool on the live view image, and then selecting X tab in the Plots window will reveal
a cross-section plot of your image. Viewing this plot allows you to graphically see the sharpness of your focusing. You

can zoom in on the X-axis by clicking the Zoom Tool and then clicking on the X-axis.

Note: In the Benchtop System, the working distance is often changed to fill the imager’s FOV with the sample being
scanned on the stage. If you change the working distance, then you will need to refocus the imager and update the
Swath value under the Stage tab in the Tools panel. A good first estimate of the value for Swath can usually be made
from the ruled lines of the in-focus focusing sheet.

Focusing the Outdoor Field System can be a little more challenging than the benchtop system. If you are focusing on
objects that are further than 40 feet start the process with the objective lens screwed in close to the collar. A method that
has proven useful is to start the focusing process by increasing the number of lines scanned to 1000. This gives a large
scan area to begin the process. You will need to be out of live focus mode when performing this focusing procedure
(”F” button should not be red). When the scan begins make a quarter turn with the lens. Continue to make quarter
turns until you are confident your scene is in focus. When making the quarter turn, intentionally place your hand in
front of the lens. This will create a thin black line in the scan separating one focus length from its neighbor, allowing
for easier comparison. This process can take some time, so be patient and remember that it gets easier with practice.

Once you have completed focusing, re-tighten the lock to the focus adjustment. Then click on the Focus tool again
to toggle the camera live view off.

Note: See our YouTube video on focusing the benchtop system at http://www.youtube.com/resonon.

2.6. Focusing Objective Lens 11
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2.7 Reflectance Measurement Calibration

The following discussion describes how to set up your system to scan for reflectance scaled to a reference object. If
you wish to collect raw data and convert it to radiance do not perform the following correction process.

Note: The Dark Current button and the Response Correction Cube button are disabled in live camera view

mode. If needed, then click on the Focus tool to toggle the camera live view off.

2.7.1 Dark Correction

SpectrononPro can remove the imager camera’s average dark current from scans. Begin by clicking on the Dark

Correction button on the SpectrononPro toolbar. You will be instructed to block all light entering the imager’s
objective lens.

After you have the objective lens blocked, click OK as instructed. SpectrononPro will then collect multiple dark
frames and use these measurements to subtract the average dark current from your measurements. The Dark Correction

button on the toolbar will appear with a red check through it as soon as the dark frames have been collected . Once
you see the red check, unblock the objective lens.

2.7.2 Response Correction

Measuring absolute reflectance of an object requires correction to account for instrument-sensor-response and spatially

nonuniform illumination effects. To do this, click on the Response Correction button on the SpectrononPro toolbar.
A message will appear telling you to place a reference material within your Pika imaging spectrometer’s FOV. The
reference material should be uniform across the imager’s FOV. Examples of reference materials include Spectralon®,
Fluorilon®, or sheets of white Teflon®.

12 Chapter 2. Basic Data Acquisition
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Once the reference material is in place, click on OK. This will trigger a short scan of the reference material. Once

complete, the Response Correction button will appear with a red check mark , indicating that the data you collect
will be scaled in reflectance with respect to the reference material, including flat-fielding to compensate for spatial
variations in your lighting. Any dark correction is subtracted from the response correction.

Note: For additional help with this process see our Calibration video at http://www.youtube.com/resonon.

2.7.3 Invalidating Corrections

Once the imager is calibrated for both dark current and reflectance reference, the imager will remain calibrated until
the corrections are removed by the user, or SpectrononPro is restarted. To manually remove the corrections, click
Spectrometer → Remove Dark Correction Cube and Spectrometer→ Remove Response Correction Cube.

Dark current typically changes with the imager camera’s integration time and gain settings, the degree of which depends
on the imager camera’s particular sensor. Furthermore, the response correction is likewise invalidated by changes in
the imager camera’s integration time. By default, SpectrononPro will warn you before taking a scan if such changes
have likely invalidated one/both of the corrections. SpectrononPro does not detect changes such as illumination and
working-distance adjustments, which also invalidate the response correction.

Hint: Before collecting the dark and response correction cubes, you may first want to set the imager camera’s Fram-
erate and Integration Time while in live view and viewing the reflectance reference. Increase the Integration Time until
the signal is near, but sufficiently below, saturation over the entire frame (spatially and spectrally). Next, maximize
the scan speed by choosing the fastest Framerate for that Integration Time. (If available, then Auto Framerate Mode
can be turned on to have SpectrononPro automatically set the fastest frame rate.) Also consider the auto expose

feature accessible as the Auto Expose button in the toolbar in the Scan toolbar and described further in Section
{number}: {name}.

2.7. Reflectance Measurement Calibration 13
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2.8 Scanning and Saving Datacubes

2.8.1 Scanning with Unity Aspect Ratio

A distortion-free hyperspectral datacube with a unit-aspect-ratio image is achieved when the stage/object advances the
distance of the projected image of one spatial pixel per each line acquired at the imager’s given frame rate. Thus,
changing the Framerate setting requires updating the stage’s Scanning Speed to maintain unity aspect ratio, while
changing only the Integration Time does not. Similarly, changing the working distance of the imager to the stage changes
the object magnification (and FOV or swath width), and thus changes the aspect ratio for any particular Framerate and
Scanning Speed combination.

Hint: Typically, you want the fastest frame rate possible that supports the integration time required for the illumination
and sample brightness. This is because faster frame rates produce faster scans.

By default, SpectrononPro has Auto Speed Mode enabled, which automates required Scanning Speed adjustments
each time the Framerate changes. This depends on a single calibration parameter, the Swath setting (in cm) for the
Benchtop System, or the FOV setting (in deg) for the Outdoor Field System. Once this parameter is properly “tuned”
for a given system setup, you can freely adjust the Framerate without having to manually update the Scanning Speed,
which is updated automatically. For very low frame rates (long integration times), SpectrononPro automatically
compensates by turning on Stepping Mode and setting the proper Step Size.

Benchtop System

To determine the Swath setting for the Benchtop System, it is useful to first scan an object whose distortion is easy
to observe, such as a circle. Print out the Pixel Aspect Ratio Calibration Sheet provided in Focusing & Calibration
Sheets for this purpose. After placing an object with circles within the FOV of your imager, record a scan with enough
lines that you can see the complete circle. (500-800 lines are usually sufficient.) Record the scan by clicking on the

Scan Button , and a waterfall RGB image should appear in the Image Panel of SpectrononPro. You may need to
record several trial images to determine how many lines to scan and where to best position the object.

Hint: Stop a scan by re-clicking on the Scan Button , which changes to the Stop Button during the scan.

If the aspect ratio of the image is distorted, then you will need to change the Swath setting on the Stage tab on the Tools
panel. If your image is elongated along the scan direction, then the stage was moving too slowly in relation to the frame
rate (over-sampling), and you should increase the Swath setting, which automatically increases the Scanning Speed.
Conversely, if your image is compacted along the scan direction, then the stage was moving too quickly in relation to the
frame rate (under-sampling), and you should decrease the Swath setting, which automatically decreases the Scanning
Speed. Repeat the above process until your image is no longer distorted, as pictured below.

14 Chapter 2. Basic Data Acquisition



Benchtop Quick Start for Spectronon Version 3.4.11

It is also possible to measure the swath directly by imaging the vertical lines of the provided Focusing & Calibration
Sheets. Count the number of lines, and use the width between each line to estimate the total width, which is the swath
width. This can even be done at the end of the imager focusing described in Section {number}: {name}.

Outdoor Field System

To determine the FOV setting for the Outdoor Field System, simply use the (far-field) FOV value specified for the
imager’s objective lens, which assumes the objective lens is focused at infinity.

Note: For help setting the aspect ratio without using Auto Speed Mode see our Setting Aspect Ratio video at http:
//www.youtube.com/resonon.

2.8.2 Scanning Objects

To scan an image of an object after calibrating the system, place the object on the stage within the imager’s FOV and

type in the number of lines you would like to scan in the window just to the left of the Scan Button . Record a

hyperspectral datacube (the image) by pressing the Scan Button . (Click to terminate the scan early, if needed.)
Adjust the stage position and increase/decrease the number of lines as needed to cover the object’s feature(s) of interest.

A waterfall image of your datacube will appear in the Image Panel of Spectronon, and a new entry labeled Current Scan
will appear in the Resource Tree. To save the scanned datacube, use your mouse to select Current Scan and then either
right-click or select Datacube → Save Cube. This will open a dialog window that allows you to name the datacube and
save it in a folder of your choosing. If you do not save your datacube, the current scan will be overwritten when you
record another datacube, and a warning should appear.

2.8. Scanning and Saving Datacubes 15

http://www.youtube.com/resonon
http://www.youtube.com/resonon


Benchtop Quick Start for Spectronon Version 3.4.11

Hint: For additional help scanning and saving datacubes see our Scanning and Saving video at http://www.youtube.
com/resonon.

Once a datacube is scanned, you can use all the visualization and analysis tools of Spectronon[Pro] on your datacube
image, as introduced in Section {number}: {name}.

16 Chapter 2. Basic Data Acquisition
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CHAPTER

THREE

BASIC DATA ANALYSIS

Spectronon provides visualization and manipulation capabilities for hyperspectral images. SpectrononPro software
has all the features of Spectronon, but also enables data acquisition from Resonon’s family of imagers. Spectronon
software can be downloaded for free on Resonon’s website http://www.resonon.com/. SpectrononPro comes bundled
with any of Resonon’s imaging spectrometers. Additional analysis capabilities are available in software packages such
as ENVI®.

This section begins with basic operation of Spectronon, such as opening a hyperspectral datacube and viewing the
data. A complete description of visualization tools is provided in the Spectronon user manual sections Advanced
Data Analysis 1-3. The Spectonon custom plugin manual discusses how to implement user-written algorithms into
Spectronon, enabling custom data analyses.

3.1 Spectronon Tools

To open a datacube, select File → Open Datacube.

This will open a dialog that allows you to browse to find your datacube. Select your datacube and click on Open to load
your datacube. This will result in the following:

• An image of your datacube will appear in the image panel

• A listing of the open datacube will appear in the Resource Tree

• Tabs will appear in the Parameters window that allow you to change the image (more on this later)

• Header information on your datacube will appear in the information panel

17
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Note: Spectronon can open any datacube with an ENVI© formatted header. This includes .bip, bil, and .bsq formats.

This chapter employs an example datacube of M&M® and Reese’s® Pieces candies. (This datacube can be downloaded
from Resonon’s website at http://downloads.resonon.com/.) By default, the datacube is opened with a true color image
of the data, which approximates the appearance of the object under normal lighting conditions by combining red, green,
and blue wavelengths from the datacube.

With a few minutes of practice using the available tools, you will be able to manipulate and visualize hyperspectral
data quickly and efficiently.

3.2 Zoom, Pan, Flip, and Rotate Tool

To zoom to a specific area of the image, select the magnify tool in the toolbar and the cursor will change.
Click the magnify tool in the image, and the view will zoom in. It is also possible to click and drag a selection within
the image to zoom into the selected area.

To zoom out, select the demagnify tool and click anywhere in the image.

18 Chapter 3. Basic Data Analysis
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To zoom all the out and recover the original image, select the original size tool and click anywhere in the
image.

The user may also zoom in and out using the mouse scroll wheel, if available.

To pan the image while zoomed in, select the pan tool. Click and drag inside of the Image to pan.

Click these tool to rotate left, rotate right, flip vertically, or flip horizontally the
image.

3.3 The Inspector Tool – Spectral Plots

The inspector tool allows you to see the spectrum associated with a pixel. Choose the inspector from the
toolbar, and then click a point inside the image. This will:

• Plot the spectrum for the pixel in the spectrum plot panel

• List the pixel location (sample and line number) in the data panel

• List the red (R), green (G), and blue (B) brightness values in the data panel
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Click on other pixels to see the spectra from other pixels, click and hold while dragging the inspector tool to update
the plot panel continuously.

The red, green, and blue vertical lines in the spectral plot indicate the hyperspectral wavelength bands used to generate
the current image.

3.4 Region Of Interest (ROI) Tools

It is often useful to consider a group of pixels within the image. The ROI tools enable this capability and provide a
number of options. As will be seen later, the ROI tool is often used during one of the first steps in classifying different
objects within a hyperspectral image.

To select a Region of Interest (ROI), select either the marquee , lasso , or flood fill (wand)
tool from the menu bar. Click and drag a rectangle of interest with the marquee tool, or click and drag any closed shape
with the lasso. The floodfill tool can be used to select a contiguous region of spectrally similar pixels. After selecting
an area, right-click to reveal a pop-up menu with several options. Holding control while selecting ROIs allows you to
append to the existing selection.
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Fig. 1: A small ROI on one of the red candies has been selected and a right-click has revealed the popup selection
menu.

Hint: The selection menu is also available in the main menu.

The floodfill tool shows pixels that are spectrally similar to the chosen pixel. Spectral similarity is assessed with either
Euclidean distance or Spectral Angle Mapper (SAM), along with a tolerance value. The user can set these options by
accessing the Workbench tab from File → Preferences menu.
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The use of the floodfill tool depends on an adjustable tolerance parameter. Floodfill operates on a representation of the
datacube scaled from zero to one in each band. It calculates the Euclidean distance or SAM angle in spectral space
between the clicked pixel and all contiguous pixels and expands the selection until the selected area contains all of
the contiguous pixels for which the spectral distance to the clicked pixel is less than the selected tolerance. Increasing
the tolerance will result in a larger selected region with greater spectral variability within that region (i.e. it allows
pixels that are less similar to the clicked pixel to be included in the selection). Decreasing the tolerance will result in
smaller selected regions with greater spectral similarity. As with the other selection tools, holding control while using
the floodfill tool will allow a selection to be built up through multiple clicks of the tool.

An ROI consisting of multiple parts of the image has been selected by using the floodfill tool several times.

One of the most useful selection options is mean spectrum. (Descriptions for the other ROI options can be found in
Basic Data Acquisition.) Selecting the mean spectrum option calculates the mean spectrum of all the pixels within
the ROI area you selected and plots the result in the spectral plotter. Standard deviation can be shown as an envelope
around the spectrum plot. Show or hide the standard deviation envelope with the Show / Hide Standard Deviation
menu items.
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Individual spectra can be selected by clicking on the graph of the spectra. You can crop an individual spectrum by
selecting it, selecting a rectangular region in the plot window, right clicking to bring up the menu, and selecting crop
spectrum. You can also set the range of the plot by selecting Plots → Spectral Plotter → Set Range.

Hint: To examine the plots in more detail, you may resize the plot panel boundary by dragging the edges. Alternatively,
click on the magnify tool, then click or drag in the spectral plotter to zoom in. The pan tool will allow you to pan within
the spectral plotter as well.

Selecting Mean Spectrum creates a new entry in the resource tree under a new heading, spectra. Right-clicking on the
spectrum in the resource tree or selecting Spectrum from the menu bar will reveal a menu of options. Some of the most
used options are listed below.
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Save Spectrum

Change the name and save the spectrum as a file.

Set Label Color

Open a color picker dialog to change the label color of the spectral plot, and as shown later, classification areas based
on this spectrum.

Show Region

Show the originally selected area for the ROI in the current image. This option is useful after you have selected several
ROIs.

The color and transparency of the selection can be modified by selecting File → Preferences. The selection options
are located in the workbench tab of the preferences window. A selection transparency of 1 represents a completely
transparent selection (the selection will not be visible), while a selection transparency of 0 represents a completely
opaque selection (the underlying render of the datacube will not be visible through the selection).
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3.5 Image Visualization

Hyperspectral data can be visualized in far more ways than conventional color images. Image controls are provided in
the tool control panel.

By default, the image is displayed in True Color, which means three representative bands are used to generate a red-
green-blue (RGB) image, approximating how it appears to a human eye. The Color Infrared preset option provides
a false-color RGB image with the red band set to an infrared wavelength. This option is useful for live vegetation
datacubes.

Any time you wish to restore the image to true color, simply click on the True Color button under Presets.
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To generate false color images, use the sliders or arrows to change the wavelength bands used to create the RGB Image.
This tool is often useful when trying to visualize specific spectral features associated with an object in your image. If
Auto Update is not selected, click Update to generate the new image.

The Mode menu allows you to identify the band by wavelength (typically the most useful), or by band number.

As an example, of how false-color images can reveal interesting features, move the red slider to approximately 593 nm,
and the green slider to approximately 516 nm, then click Update. This generates a new false-colored image, shown
below, that reveals there are actually two kinds of red candy, and suggests there are two kinds of yellow candy – each
candy type is positioned in the shape of an “I”. In the Spectronon user manual section Advanced Data Analysis 2:
Hyperspectral Classification a classification technique shows this more clearly.
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Note: The Red, Green, and Blue vertical lines in the Spectral Plot show the location of the bands chosen to create the
false-color RGB image.
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The Contrast tab in the tool control panel allows you to adjust the image contrast. If Use Contrast Enhancement is not
checked, no image enhancement will be done and the tools in the Contrast tab will be not be active.

Note: Contrast enhancement does NOT change the hyperspectral data. It only changes the way the image appears.

Generally, contrast enhancement is beneficial. The 2% stretch is the default, and it sets the darkest 2% of the pixels in
the image to a value of 0, and the brightest 2% of the pixels in the image to maximum brightness (255). This choice
minimizes the impact of glare. You can customize the percentage of the dark pixels set to 0 and the percentage of the
bright pixels set to 255 with the sliders. The Linear stretch option sets these percentages to zero.

The Inverse checkbox is useful if you wish to highlight dark pixels.

The Individual Bands checkbox controls whether the brightness levels of the three image layers are considered all
together or as individual layers.
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It is often useful to view a single band in a standard grayscale (black-and-white) image to visualize the impact of a
single spectral feature. To do this, go to the main menu and select Datacube → New Image → Greyscale.

The controls are similar to the RGB controls. If Auto Update is not checked, be sure to click Update after moving the
slider to see the grayscale image for a new band.

As with the RGB images, a vertical line in the Spectral Plot shows the band you have chosen. Note that even though
the image is from a single band, the Inspector and ROI Tools will continue to plot and operate on all wavelengths.
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Hint: With Auto Update selected in the tool control panel, you can quickly scroll through single band images.

Warning: For large datacubes or slow computers, the Auto Update refresh rate may be slow.

3.6 Plot Panel

The plot panel allows you to visualize hyperspectral data graphically. This has already been seen with the use of the
Inspector and ROI tools, but here we explore the plot panel in more detail.

The plot panel has three tabs: Spectra, X, and Y. These three tabs provide you with plots along the three axes of a

datacube using the Inspector Tool , as shown below.

Clicking on the X and Y tabs in the plot panel accesses the corresponding cross-sectional plots. The plot will show
the intensity versus position value for the RGB bands used to create the image or the Grayscale band if used with a
grayscale image.

Note: The direction of X and Y depends on the orientation of your cube. Moving the Inspector Tool should reveal
which axis you are plotting.
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Hint: Use the magnify tool , the demagnify tool , and the pan tool in the spectral plotter
to navigate and examine features.

3.7 Saving Spectra, Plots, and Images

Spectronon makes it easy to save the results of your work for further investigations or for making presentations.

To save a spectrum, click the spectrum you wish to save in the Resource Tree, and then you may either (1) use the
Spectrum menu in the main menu, or (2) right-click on the spectrum in the Resource Tree to reveal the menu shown
below. From this menu, select either Save Spectrum or Save Spectrum As. . . This will open a save dialog. Once saved,
the new name will appear when the file is plotted in the spectral plotter, and the file can be re-opened for use in later
sessions.

Select the menu option Copy Spectrum As Text to copy the data onto your clipboard, from which you can paste it into
other applications such as Notepad and Excel.

To save a plot use the Plots menu as shown above. Select which plot you wish to save (Spectral Plotter, X Cross Section,
or Y Cross Section), and then select Save as Image to save as an image or Save as Text to save the plotted data as tables
in text file. Both options will pop up a save Dialog.
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To Save an Image, select Image from the main menu, and then Export Image. . . This will pop up a save dialog.
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CHAPTER

FOUR

FOCUSING & CALIBRATION SHEETS

Use the focusing sheets to focus the objective lens, and use the aspect ratio calibration sheet to set the stage speed and
imager framerate. See the Basic Data Acquisition for details.

4.1 Small Focusing Sheet
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4.2 Large Focusing Sheet
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4.3 Aspect Ratio Calibration Sheet
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CHAPTER

FIVE

RECALIBRATION SERVICES

Resonon recommends a yearly schedule for wavelength and radiometric calibration for best performance, or immedi-
ately after rough handling. Please contact us below for a quote and instructions.
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CHAPTER

SIX

PRODUCT SUPPORT

Please contact Resonon by phone, email, or via the form on our website:

Phone: 1.406.586.3356
Website: https://resonon.com/support
Email: support@resonon.com
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CHAPTER

SEVEN

COPYRIGHT NOTICE

Copyright © 2016 - 2023 Resonon Inc. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or by any means (electronic or mechanical,
including photocopying) for any purpose without written permission from Resonon. Resonon will not be responsible
or liable for any accidental or inevitable damage that may result from unauthorized access or modifications.

This document may contain errors or inaccuracies, and it may be revised without advance notice. This manual is
updated frequently.

Please see our software copyright and EULA at
https://resonon.com/content/files/Resonon-Software-EULA_Sept2016.pdf

Resonon welcomes any recommendations regarding this manual. Customer feedback is always welcome as it helps us
to continuously improve upon the quality of our products.

Please contact us at Resonon with any questions or comments. We look forward to hearing from you.
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